Полная версия

Главная arrow Информатика arrow MS Excel: виконання обчислень в таблицях

  • Увеличить шрифт
  • Уменьшить шрифт


<<   СОДЕРЖАНИЕ   >>

Копіювання формул за допомогою команди Заповнити в меню Правка

При повторних обчисленнях по одних і тих же формулах можна скористатися ще одним способом копіювання формул -- командою Заповнити (Fill) у меню Правка (Edit). Як приклад використовуємо цю команду для знаходження середнього арифметичного значення даних по стовпцях у вічках В10 і В11, З10 і З11 D10 і D11 (мал.).

Введемо у вічка вихідні дані.

Поставимо курсор у вічко В12 і виберемо команду Функція (Function) у меню Вставка (Insert).

У діалоговому вікні Майстер функцій -- крок 1 з 2 (Insert Function) (мал.) в списку Категорія (Function category) в списку, що розкривається, Категорія виберемо рядок Статистичні (Statistical) у списку Виберіть функцію (Select а function) елемент СРЗНАЧ (AVERAGE) і натискуватимемо кнопку ОК. У діалоговому вікні Аргументи функції (Function Arguments) (мал. 16.6). Майстер функції запропонує знайти середнє арифметичне значення у вічках В10:в11. Після натиснення кнопки ОК у вічку В12 з'явиться результат.

Мал. Копіювання формул за допомогою команди Заповнити в меню ПравкаВиділимо вічка В12, С12 і D12.

Виберемо в меню Правка (Edit) команду Заповнити (Fill), Управо (Right).

Формула з вічка В12 скопіюється у вічка С12 і D12 і ми побачимо результати обчислень. Якщо у вічку В12 знаходилася формула =СРЗНАЧ(В10:в11) (AVERAGE)(B10:B11), то в ячейках'С12 і D12, вона набере відповідно вигляду =СРЗНАЧ(С10:с11) і =CP3HA4(D10:D11).

Відображення формул на робочому листі

Вміст поточної коміркм можна переглянути як у самій комірці, так і в рядку формул. Однак для цього потрібно зробити деякі додаткові дії: або двічі клацнути по комірці, або клацнути по комірці і потім - по рядку формул. Але якщо формул на листі нагромадилися досить багато, зручно скористатися режимом одночасного відображення на листі усіх формул. Однак, при цьому на екрані значення в комірках заміняються формулами. Але, такий режим значно зручніший, коли проводять громіздкі обчислення.

Перейти до режиму відображення усіх формул на екрані можна в такий спосіб:

† ввійти у меню Сервис;

† вибрати команду Параметры і відкрити вкладку Вид;

† у розділі Параметры окна встановити прапорець Формулы і натиснути ОК.

У цьому режимі стовпці автоматично розширюються до розміру формул так, щоб формули були краще видні. Якщо потрібно повернутися до колишнього режиму відображення таблиці, то знову виконати команду Сервис > Параметры > вкладка Вид і зняти прапорець Формулы.

Система адресації в Excel. Адреси Робочої книги, листа, осередку

Робоча книга в Excel містить безліч аркушів, а кожний лист - безліч комірок. Коли клацнути мишею в якому-небудь місці таблиці, - виділиться конкретна комірка, що належить визначеному листу, розташованому у визначеній Робочій книзі.

Найбільш великим об'єктом у Excel, призначеним для збереження й обробки даних, є Робоча книга. Книга в Excel являє собою файл, а адреса файлу, як відомо, указується за допомогою імені файлу і шляху до нього, наприклад:

С:Мої документиНакладна.xls

- це «адреса» файлу Накладна.xls у просторі імен Windows. У системі Excel, щоб звернутися до якої-небудь Робочої книги, потрібно записати посилання на цю книгу-файл. Посилання на Робочу книгу буде нагадувати адресу файлу, однак буде трохи відрізнятися від нього:

С:Мої документи[Накладна.xls]

Якщо Робоча книга під ім'ям Накладна уже відкрита в Excel, то посилання на неї записується просто як ім'я файлу в прямих дужках:

[Накладна.xls]

Робочий лист вказується в посиланні слідом за ім'ям Робочої книги, а комірка - слідом за ім'ям листа через знак оклику. Наприклад, настпниий запис

[Накладна.xls]Склад!В3

відповідає посиланню (чи адресі) комірці В3, розташованої на листі Склад Робочої книги Накладна.

Описана система адрес зручна, коли в розрахунках беруть участь не одна, а декілька взаємозалежних Робочих книг.

 
Перейти к загрузке файла
<<   СОДЕРЖАНИЕ   >>